VW Tiguan Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2011 tig Hi, I really need some help with this. while driving the other day I suddenly lost my power steering assist fault with salad red icon on dash. I pulled over and did what I needed to do got back in the car and it wouldn't start I hooked up my OBD2 and I've got no communication with anything. just asked me if I'm sure my car is compatible with the OBD2 and to check the plug. want to switch it to the for VW mode I do get codes but they're all U codes specifying no communication with ecm, tcm, bcm, aircm, dash, steering, power train, instrument cluster, data bus no signal etc. everything except the immobilizer which it says is okay. car starts immediately then dies. there are two relays in the engine compartment fuse box A1 and a2 one of them is clicking constantly? also, I think this is a separate problem but a few days ago all the controls on my steering wheel quit working. this car has been a complete lemon and it's driving me crazy. I had to replace the intake manifold the coils, injectors, plugs, water pump cleaning intake ports etc etc, couldn't finish the drive cycle to get a smogged because 5 days later the timing chain jumped and bent all the valves, $2,500 later I'm trying once again to do the drive cycle and this happened. honestly if I don't get it fixed i am going to be homeless and I'm too old for that. :) Any advice or suggestions to help me figure this out with you so much appreciated thank you
 

Attachments

·
Administrator
Volvo XC40, formerly 2015 match 177ps 4mo DSG
Joined
·
2,441 Posts
There is a fuse protecting the OBD2 interface, maybe this is the cause?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I've checked all the fuses I appreciate the advice though also the OBD2 does power up when I plug it in and I do get a message that says I should check and make sure my car's compatible and there's no communication
 

·
Premium Member
Joined
·
4,070 Posts
Most generic OBD readers do this. You need a Canbus friendly setup like VCDS or OBD11.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Mine has a seperate switch for vw. that is why i have the codes i do. To add to the mystery. There are two relays in fuse box in engine compartment. I noticed one clicking like crazy. they both check fine but when i try to check where they mount, it gets crazy. every time i check for power i get different readings. sometimes on one of them significantly higher than 12v As far as continuity to ground sometimes, or i get o.l. than i check it and i have continuity to power. Everything i am seeing is leading me to think I have some sort of a short, somewhere.I am unclear how to find that but it occured to me the event that took place right b4 everything hit the fan was a power steering assist failure so i am going to look at that. Sadly everytime i think i might understand it i realize i couldnt be more wrong, lol
 

·
Administrator
Volvo XC40, formerly 2015 match 177ps 4mo DSG
Joined
·
2,441 Posts
You're using a generic device and interpreting the results as fact. Your randomly testing points with no circuit diagram, you might as well be pinning the tail on the donkey for all the good you're doing.

Firstly, get a proper VW diagnostic tool, in order of cost VCDS OBDeleven or Carista, will all give good trustworthy diagnostic results.

Secondly there are several discussions on here that can point to getting circuit diagrams and relay layouts which may give a clue to what you're probing.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
update ongoing issues, well the first mechanic finally told me that he couldn't fix it and suggested another one here in town. had it towed "third time" to them. first they didnt want to work on it because park brake locked up. i ordered a new parking brake control lever from amazon for $23.00 one day delivery after calling dealer ($164.99 two day delivery) it worked brake released and they are working on it now. .....fingers crossed
 
1 - 9 of 9 Posts
Top