VW Tiguan Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
Hi I'm after some advice, my car 2010 tiguan tdi started up the other day and my dash pinged up with a oil sensor workshop light fault.
A autohold parking brake fault
And both buttons for the Traction and stop start don't work .
These all started together and they can't be cleared ....I did have a new stop start battery fitted a few weeks ago and it was coded to the car ...we're going away next week so could do with sorting it
 

Attachments

·
Administrator
Volvo XC40, formerly 2015 match 177ps 4mo DSG
Joined
·
2,423 Posts
OK, so you've posted this twice! I'd still favour electrical, you say you had a new battery fitted, by a reputable garage? Could still be loose connection, have you checked the battery connections? Also possibly earth strap from engine to chassis under the car.
 

·
Premium Member
Joined
·
4,146 Posts
First off trust this type of scanners results with a grain of salt. They are most inaccurate. You need a VW capable and canbus enabled scanner. All these codes can point to one thing. Voltage related. You have a battery issue or a charging issue.

Scanning with VCDS would come back with a host of low voltage or short to ground codes these scanners cannot read.

VWs take specialty tools to properly diagnose. Using inferior tools results in you spending more money tossing parts at it that are not needed.

As Tricky mentioned and I'll reinforce. Check the ground strap from the chassis to the transmission under the air intake box. They corrode and cause issues. And if you are handy add a couple more ground straps. For good measure
 
1 - 4 of 4 Posts
Top