VW Tiguan Forum banner
1 - 20 of 21 Posts

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #1 · (Edited)
Hood Luggage and bags Motor vehicle Bag Bumper
Automotive parking light Tire Vehicle Hood Automotive lighting
Hood Motor vehicle Automotive lighting Automotive tire Vehicle door
Textile Sleeve Grey Gadget Personal protective equipment
Electrical wiring Motor vehicle Auto part Cable Wire


(solution post #13)

Oddly the thread I started a while back about the transmission shudder disappeared. Little history at 50k I had my Tiguan at the dealer for another service and asked to have the Transmission serviced. They hinted it was unnecessary as it's supposed bto be a lifetime fill no service requirements for it. I am a firm believer that no fluid can last 100k miles. So they serviced it by dropping the fluid and refilling. (Soni thought). About a month ago I started exhibiting issues in the transmission, hard shifting, random shifting,. And wanting to drive in town at 35 mph and it would drop into 6th and Lock the torque converter so I'd be lugging around at 900 rpm making a ton of noise and shake. Driving in sport mode would help, but oddly when it would be in 6th I could manually down shift and it would usually pop into 3rd or 4th. Same with cruise. So I knew the computer knew what gear it wanted but the TCM thought otherwise due to pressures etc. No codes, all solenoids checked in fine.

So I ordered a service kit with fluid Shawng highly recommended readapted my DSG fill tool for the 09M. Pulled the drain plug and I had fluid gushing out. Stuck the 5mm Allen in to find the insert dip stick was loose. Even after snugging it up I still had a bit too much fluid coming out for the temperature. So I was over full??? So I pulled the insert totally drained the pan. Fluid didn't smell burnt so that's a huge win but it definitely smelt old . Well used for sure. Pulled the pan, and it was definitely well past due for Service. Magnets were covered and did their job. A bit of speckles in the fluid in the pan, and the filter screen and too was covered in a light grey film. All signs of old fluid. Cleaned up everything on the solvent tank. Cleaned up the magnets and stuck them back in installed the new filter, and gasket and followed the guide below to refill. I might of left it a bit over full as I got about 5.5 liters in and dropped a bit, but the fluid was pushing 45C when I did it.

Under the advisement of Shawng I'll probably drop the fluid again in a few thousand to get rid of more if the fluid.

Blauparts has a wonderful DIY guide for the 09M service. It's honestly not that hard. I built my own fill tube using fittings and a funnel. Pan threads are M10x1.0! Found a barbed fitting on Amazon. And went to work. It's a slow fill process as the insert is like a straw. Patience is key.

How To Change VW Transmission Fluid (2002-2018 Aisin 6-Speed)
 
  • Like
Reactions: Ianator157

·
Registered
Joined
·
67 Posts
Nice! Thanks for the info and photos; I’ll be doing this very soon. Did this on my 2003 Jetta with 5-speed tiptronic trans, and seems pretty straight forward and similar. Wonder if I can get the trans temp reading on my OBDEleven ?
 

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #3 ·
Obd11 should show trans temp.
 
  • Like
Reactions: Ianator157

·
Premium Member
Joined
·
4,146 Posts
So the transmission is still acting up, now it can't figure out what gear to be in half the time, still no codes. So I dropped into a local family owned shop my dad's dealt with for over 20 years, he got in and a quick drive down the road it fast shifted to second, then to fourth and then 6th lockup. Stopped shifted better. Turned around shut the key off and back in shifted like butter normally. Went back he reset the transmission with his tool and test drove it to a few random glitches. Will leave it with him later this week so he can do a cold fluid bruh with his tool recording everything. He is thinking it's the TCM, but said yes replaced a few valve bodies but only in 09Gs said the Ms are bulletproof. So will know more later.

BTW: where is the TCM??? It's not in the wheel well like they said or on the frame rail near the transmission.
 
  • Like
Reactions: Ianator157

·
Registered
Joined
·
740 Posts
Some shops have a specific tool used to fill transmissions, it looks and operates like a garden sprayer, like a Motive Power Bleeder for flushing your brake fluid... something like that will make it easier to fill, but... since a home mechanic may not use it a lot it's probably not worth the money.
 

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #6 ·
I used my rig I used for filling DSGs fluid just redid the plug end and it worked great just slow going. We are hoping it's electric and the TCM as it's been shifting just fine for a few days and a long freeway run then today it's back to acting goofy. At least we ruled out the transmission is going out. It's either the value body solenoids or the control. Will know more when he hooks up his service tool. Says it shows even more than vcds can shown would of done it today but I needed to head home due to prior obligations.
 
  • Like
Reactions: Ianator157

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #7 ·
So the shop thinks it's the valve body. It's definitely struggling in a few gears, 3rd teys to engage lockup and falls on its face and kicks in and out of lockup till it slams into 4th. He thinks the torque converter and clutches are okay. We are discussing next steps he wants me to leave it with him next week over night so he can do a cold scan and run. But if things are looking like the valve body we are ordering a Sonnax it's a bit more expensive but it will hold up to the tune. But I'll be able to do it myself if I want said it's not a terrible job to replace as he knows funds are a bit limited. But once done he wants it back to do a power flush. He can remove the bulkhead fitting to the cooler and flush out the converter.
 
  • Like
Reactions: Ianator157

·
Administrator
Volvo XC40, formerly 2015 match 177ps 4mo DSG
Joined
·
2,423 Posts
OK, oddball suggestion. Way way back, before I got into VW's, I had a Jaguar S type, with conventional auto and torque converter. It suddenly started kicking down randomly when just quietly cruising along. Frightened s**t out of me the first time it did it at around 80 mph! Thought the engine had dropped out.

It then started doing it very regularly, to the point i couldn't use the car anymore. Took it to an auto box specialist. They fitted new box, still it was doing it. They eventually got master techs from the box makers involved, and it turned out to be the spark plugs!! Long life plugs, yes due for a change in the near future, they reckoned it was generating noise that was triggering the box.

New box and new plugs later it was a happy car again, but i'd lost faith and before long exchanged it for a brand new Passat. I really loved the time with the jag, but I needed reliability and it had cost me too much.
 

·
Administrator
Volvo XC40, formerly 2015 match 177ps 4mo DSG
Joined
·
2,423 Posts
That was an expensive set of plugs tricky!
Tell me about it! All the signs were the box with it randomly changing down sometimes several gears. They'd already swopped the box so there was no choice, cost me 3 grand a decade back! So you can see my time with the S type was bitter sweet.
 
  • Like
Reactions: stevey83

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #11 ·
New plugs and coils fitted all fluids serviced. :( They think it's the Valve body. He's had a few of them do this exact thing. 09G was far worse at this exact issue.
 
  • Like
Reactions: Ianator157

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #12 ·
Well the shops tool couldn't read the transmission. He agrees it's shifting weird but can say it's not slipping. It's just acting mixed up. Suggested doing a fluid change again soon as that seemed to remedy part of it. If it keeps up then look at the TCM. He thinks the internals are okay.
 
  • Like
Reactions: Ianator157

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #13 ·
To close this thread out. After 3 shops of no solution, a fellow Wrench told me to check the ground strap to the transmission. Sure enough it was corroded. The same ground I mentioned many times if having issues. Been driving like a dream again for the last 200 miles. Maybe even better with the fresh fluid in it. Lots of hours wasted thankfully all but one shop didn't charge me a dime. The one that did said hey it's about lunch for grab us an assortment of $5 Dominos Pizzas. $20 is all that cost. But yep ground strap caused the issue.
 

·
Administrator
Volvo XC40, formerly 2015 match 177ps 4mo DSG
Joined
·
2,423 Posts
Interesting, given my post #8 where mine was electrical interference also.
 

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #16 ·
I'm more blown away that how much contact it needs. It wasn't corroded too bad but definitely wasn't tight. If it kept going it would of got worse. I'm adding a second strap to the rear of the transmission to the body as well.
 

·
Premium Member
Joined
·
13,682 Posts
Sounds like a good idea to me mate.
 

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #18 ·
As much as the last fix solved 90% of the issue I still had one. It would still stumble around when cold, and still be wonky in 3rd occasionally. So I yanked the fender liner out, removed the TCM and turned the Key on, started it, then shut it off, and jumped out within 30 seconds to hard reset the TCM. While I was in there I probably knocked out 5 pounds of sand and dirt, and cleaned the wheel well, and sprayed under coating on the metal. Went for a quick drive to 100% improvement. Will see how it is from a cold start tomorrow when I get up early. It no longer did the strange thing in 3rd it will now shift to 4th like it should. Fingers crossed!
 
  • Like
Reactions: Ianator157

·
Premium Member
Joined
·
4,146 Posts
Discussion Starter · #19 ·
Well.to put a period on this topic I finally broke down and bought the latest revision of TCM and it cured everything. I even picked up 1-2 mpgs which is super helpful right now. $4.75 a gallon here right now for 95 Ron/ 92 AKI. And I have a ton of miles I have to drive in the coming weeks.
 
  • Like
Reactions: Ianator157

·
Registered
Joined
·
67 Posts
Well.to put a period on this topic I finally broke down and bought the latest revision of TCM and it cured everything. I even picked up 1-2 mpgs which is super helpful right now. $4.75 a gallon here right now for 95 Ron/ 92 AKI. And I have a ton of miles I have to drive in the coming weeks.
So this is a new OEM TCM? Did you have to get it through the dealer? Very interesting, and thanks for keeping the group up to date on the whole process.
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top